[solved] weird audio crackling with certain vanilla spcs

Need help with any SMBX game-related issues? Ask your questions here.
loop
Ninji
Ninji
Posts: 984
Joined: Sun Apr 17, 2016 5:56 pm
Flair: i may be dumb but im not stupid!
Pronouns: he/him/they

[solved] weird audio crackling with certain vanilla spcs

Postby loop » Wed May 24, 2023 2:47 am

i was playing through ti2 again recently and i noticed during gameplay that i got some absolutely deep fried crunches (just now figured out that crackling is probably a better term) in the bgm used for smb3 and smw castles and the respective boss tracks

but i dont get these issues with the pge musplay or otherwise software that can play spc files
just wondering if its an issue on my end, and if so, if theres a way i can fix this
Last edited by loop on Wed Jun 07, 2023 1:50 pm, edited 1 time in total.

Wohlstand
Van De Graf
Van De Graf
Posts: 2006
Joined: Tue Feb 11, 2014 4:44 pm
Flair: [ˈvoːlˌʃtant], 狐エンジニア
Pronouns: he/him
Contact:

Re: weird audio crackling with certain vanilla spcs

Postby Wohlstand » Fri Jun 02, 2023 6:16 pm

If I guess right, sounds like it's a result of a clipping: Looks like your local setup is wrong, you need to set up the f32 sample format instead of s16.

loop
Ninji
Ninji
Posts: 984
Joined: Sun Apr 17, 2016 5:56 pm
Flair: i may be dumb but im not stupid!
Pronouns: he/him/they

Re: weird audio crackling with certain vanilla spcs

Postby loop » Fri Jun 02, 2023 8:24 pm

Wohlstand wrote:
Fri Jun 02, 2023 6:16 pm
If I guess right, sounds like it's a result of a clipping: Looks like your local setup is wrong, you need to set up the f32 sample format instead of s16.
sounds like it should be simple enough to set up, but where do i go for it? im not particularly used to smbx2 lol; havent been around in a couple years so im trying to acclimate to it again

Wohlstand
Van De Graf
Van De Graf
Posts: 2006
Joined: Tue Feb 11, 2014 4:44 pm
Flair: [ˈvoːlˌʃtant], 狐エンジニア
Pronouns: he/him
Contact:

Re: weird audio crackling with certain vanilla spcs

Postby Wohlstand » Sat Jun 03, 2023 5:08 pm

Huh, it doesn't provide an abiltiy to change the sample format, but, you can tweak other things:
- open the "data/config/luna.ini" file
- find the "Audio" section
- add the "buffer_length = 1024" field (if specified a lesser value)
- Try to run the game again
- If you still hear the cracking result, you may want to try put the "driver = directsound" field too. Some another small hope to resolve the problem.

loop
Ninji
Ninji
Posts: 984
Joined: Sun Apr 17, 2016 5:56 pm
Flair: i may be dumb but im not stupid!
Pronouns: he/him/they

Re: weird audio crackling with certain vanilla spcs

Postby loop » Sat Jun 03, 2023 10:39 pm

Wohlstand wrote:
Sat Jun 03, 2023 5:08 pm
Huh, it doesn't provide an abiltiy to change the sample format, but, you can tweak other things:
- open the "data/config/luna.ini" file
- find the "Audio" section
- add the "buffer_length = 1024" field (if specified a lesser value)
- Try to run the game again
- If you still hear the cracking result, you may want to try put the "driver = directsound" field too. Some another small hope to resolve the problem.
awesome
that seems to have fixed the problem, tysm

Wohlstand
Van De Graf
Van De Graf
Posts: 2006
Joined: Tue Feb 11, 2014 4:44 pm
Flair: [ˈvoːlˌʃtant], 狐エンジニア
Pronouns: he/him
Contact:

Re: weird audio crackling with certain vanilla spcs

Postby Wohlstand » Mon Jun 05, 2023 8:10 am

Super!

Please add the [solved] into the title of the topic.


Return to “Help and Support”

Who is online

Users browsing this forum: No registered users and 0 guests

SMWCentralTalkhausMario Fan Games GalaxyKafukaMarioWikiSMBXEquipoEstelari